April 26, 2011

Drupal 7 Issue: Adding Image Removes Body Content with CK Editor

Share on Tumblr

We ran into a strange issue in a few of our new drupal 7 installs.  When adding new content such as a page or an article.  We would fill out the title, the body, and then upon uploading an image, the body content would instantly be removed from the screen.  To make this extremely painful, the content disappears and since no save is performed automatically (like in wordpress), the body content is lost, unless it was being copied from a notepad or other source.

We noticed this issue immediately upon updating to the latest version of CK Editor for Drupal 7.  The version was ckeditor 7.x-1.1.  As of today, we have now updated to the latest module version of CK Editor for Drupal 7 and found that this error is still occurring.  This occurs in all browsers that we have tested, Firefox and Safari on Mac.

To resolve this issue, we were forced to revert back to ckeditor 7.x-1.0 which completely resolved the issue and allowed images to be uploaded without destroying the body content with a javascript action.

According to http://drupal.org/node/735028#comment-3169740, it looks like if you try deleting the browser cache, it may clean the issue up.   At this time, we’re just happy to have it working again and will stop worrying about it for the time being.

Jeremy Oms

Jeremy Oms

Jeremy is an entrepreneur and leading manager of New Blood, Inc. Excited about all things Internet related, Jeremy spends much of his time project managing custom web applications and directing advanced search engine optimization efforts.

More Posts - Website

Follow Me:
TwitterFacebookGoogle Plus

Share on Tumblr

Related Posts

No Comments »

No comments yet.

RSS feed for comments on this post. TrackBack URL

Leave a comment